NeXT Computers

NeXT Computer, Inc. => White Hardware => Topic started by: neozeed on May 12, 2017, 09:44:49 am

Title: kmem_suballoc 1 failure
Post by: neozeed on May 12, 2017, 09:44:49 am
So as part of my adventures I wanted to install onto a native board.

I tried 2 intel boards I had picked up, a D915PLWD, and a D945GNT,D945PSN,D945PLRN

Anyways on boot up of the Rhapsody DR2 diskettes I always get the same error:

physical memory = 480.00 megabytes.
panic: kmem_suballoc 1System Panic:
kmem_suballoc 1



And from vm/vm_kern.c:


       /*
        *      Need reference on submap object because it is internal
        *      to the vm_system.  vm_object_enter will never be called
        *      on it (usual source of reference for vm_map_enter).
        */
       vm_object_reference(vm_submap_object);

       addr = (vm_offset_t) vm_map_min(parent);
       kr = vm_map_find(parent, vm_submap_object, (vm_offset_t) 0,
                               &addr, size, TRUE);
       if (kr != KERN_SUCCESS)
               panic("kmem_suballoc 1");


So I figure that large amounts of RAM are just overwhelming the thing.  Also I'd been told that Rhapsody had been 'gimped' to 192MB of RAM max, and that you couldn't have such a "large" system...

Anyways add this at the boot prompt:

maxmem=32768

And you'll get a 32MB system.  It's not 'great' but it'll get installed.  Which I'm doing now! ...   Oddly enough on a machine that refused to install NeXTSTEP 3.3 which gave nothing but disk errors, but I'm using a 'new' disk I got for $15 HKD, a WD800BB, which I've jumpered into a 'reduced capacity mode' which the installer sees as either 32GB or 2GB ...
Title: Thank you!
Post by: rey on May 27, 2017, 08:23:50 pm
It works! I was able to install Rhapsody without a malloc panic!

It was as smooth as OpenStep after that. I was surprised that OpenStep installer did not have this limit.

I used the option to install on the second hard drive. But now I can't boot my new installation because the rootdev isn't the default first drive.

I can't run the command:

maxmem=32768 rootdev=hd1a

Because I don't even have the Rhapsody boot prompt!
I have a multi OS setup on my first drive, OpenStep with others (dos, Win95, os2 warp) living in harmony with System Commander 3.51 (old version that supported OpenStep),

Has this been answered in another thread you can direct me too? Or any experimental tricks? I have full hard drive ghost backups so I'm ok to run any command.
Title: kmem_suballoc 1 failure
Post by: neozeed on May 27, 2017, 11:10:16 pm
Try using -a as a flag in addition to the maxmem.  It will prompt you to ask what disk as root..  I've been using that in my experiments with multiple disks.