NeXT Computers

NeXT Computer, Inc. => NEXTSTEP / OPENSTEP Software => Topic started by: leamanc on September 16, 2017, 12:40:26 am

Title: OmniWeb that works with HTTPS?
Post by: leamanc on September 16, 2017, 12:40:26 am
I know this has been discussed before, but I haven't been able to use any of the help in existing threads to solve my issue.

On my Mac Pro, I've set up the wrp proxy server that allows ancient browsers to surf the web. OmniWeb took to the proxy just fine for http sites, and it's very cool! But most everything's https these days, so I can't browse much with it. I get the error that OmniWeb doesn't know how to handle https URLs.

I've installed packages for openssl, the OmniWeb HTTPS plugin, and everything else recommended. Then I noticed that I have OmniWeb 2.0.x, and the README for the HTTPS plugin mentions OmniWeb 2.75b, so I figured that must be my problem. So I grabbed that from Omni's site.

In short, it fails to launch. I checked the Console and says it's a demo version that has expired. I have also tried OmniWeb 3 and get the same issue.

So, two questions:

1.) Can anyone point me to a version of OmniWeb that's not expired and known to handle https URLs if everything's set up correctly? I believe that I have everything set up correctly but OmniWeb 2.0.x will never be able to use HTTPS URLs. (If I'm wrong on that last part, then I must be missing something else.)

2.) Are there any other NeXT browsers that can handle HTTPS?

My hardware is a mono NeXTstation with a 33 MHz 68040, and I'm running OpenStep 4.2.
Title: OmniWeb that works with HTTPS?
Post by: rooprob on September 19, 2017, 10:47:55 am
Other than javascript/css for the human side of the web, you'll be able to have fun with REST APIs, but to get to the modern TLS standards you're going to have to proxy your plain HTTP into (at least) TLS v1.1 and 1.2.

Haven't tried it yet, but something like this perhaps ?

I have managed to get openssl 1.0.2k to build on OS (i486/m68k) but it's not behaving with CA validation on m68k. Does work on the i486 version of OpenSTEP 4 though.  I have a build of curl 7.54.0 with it, which will work with tls1.2 and will connect, for example, to Not packaged, only a binary.  Trying to see about recompiling the m68k version while I'm typing this...