NeXT Computers

NeXTComputers.org => Site News => Topic started by: Nitro on April 23, 2019, 01:20:35 am

Title: New Forums
Post by: Nitro on April 23, 2019, 01:20:35 am
Welcome to the new forums.  My apologies for the extended downtime. Our Web server was updated with system software which broke the ancient forum software that we were using.  I wasn't able to fix the compatibility issues with the old forum software, so the forums were shut down to prevent corruption of our 14 year old database.  I spent an enormous amount of time trying to update and convert the old database, fighting every bug imaginable in software packages that I didn't write. 

The new forums offer a number of significant improvements over the old software.  The forums are mobile ready, so you can have NeXT goodness on the go with your smartphone.  You can embed/attach up to five images to your post, or files up to 3Mb in total size.  There's also a spellchecker and the ability to embed YouTube videos.  You can also switch between the default NeXT inspired forum theme and the SMF Curve2 theme.

It would be unrealistic to expect to pull off a change this big without some bumps in the road, so please let me know if you are having issues.  I know that some of the internal URL links that people have posted to other forum threads are broken.  The converter software didn't convert all of them correctly, so I'll have to go back and fix these as time permits.  Also, the NeXT forum theme is a custom work-in-progress, so you may see changes as time goes on.

If you see spam posted to the forums, please don't reply or link to it.  Just click the "Report to moderator" link at the bottom right of the offending post.  Your help to keep the forums spam-free are greatly appreciated.

If you would like to mark all forum messages as read, then look for the button near the bottom right of the main forum page, just above the info center.

If you have OmniWeb running, please let me know how the browser works with the new forum software (fingers crossed).

Thanks for your patience and understanding during the forum upgrade.
Title: Re: New Forums
Post by: t-rexky on April 23, 2019, 02:57:45 am
VERY NICE!

So far no issues.  Thank you for your hard work Nitro!
Title: Re: New Forums
Post by: barcher174 on April 23, 2019, 06:19:57 am
Thanks Nitro! Looks great!
Title: Re: New Forums
Post by: mikeboss on April 23, 2019, 01:32:17 pm
thnx a lot! greetings from switzerland.
Title: Re: New Forums
Post by: nuss on April 23, 2019, 08:09:52 pm
Thank you Nitro, great work :)!
Title: Re: New Forums
Post by: Rob Blessin Black Hole on April 24, 2019, 05:27:03 am
Thank you Nitro  all works well.
Title: Re: New Forums
Post by: krazycat on April 25, 2019, 12:04:41 am
Thank you Nitro for your effort to keep this valuable forum alive and usable  :)
Title: Re: New Forums
Post by: rumbeard on April 25, 2019, 02:38:50 am
Thanks mate, was going through withdrawal.
Title: Re: New Forums
Post by: oevl on April 29, 2019, 02:07:56 am
Keep up the good work Nitro, I am using OmniWeb 3.1rc2 on OpenStep 4.2 via Previous 2.1, the forum interface is simplified like for mobile phone use, but it's ok.
Title: Re: New Forums
Post by: bobo68 on May 01, 2019, 10:52:51 am
Great work, Nitro.

One small question: is it possible to activate secure connections (https) - at least during login?
Title: Re: New Forums
Post by: Nitro on May 01, 2019, 07:17:07 pm
Quote from: bobo68 on May 01, 2019, 10:52:51 amGreat work, Nitro.

One small question: is it possible to activate secure connections (https) - at least during login?

Thanks. I plan on switching the site over to HTTPS when we move to a new Web host, sometime before December. Our current Web host is abandoning the hosting plan that we're on, so I don't have the option at this point.  Although it's not a solution, the Firefox pester screen can be turned off until the site move.
Title: Re: New Forums
Post by: msch on May 08, 2019, 01:26:38 pm
Great - thank You very much!
Cheers
Mathias
Title: Re: New Forums
Post by: Cupertino on May 26, 2019, 07:39:07 am
I didn't come here for years but happy to see it is still alive and kicking!
So far no issues.
Now it looks nice on my iPhone!
Thanks for this update!
Title: Re: New Forums
Post by: crimsonRE on June 26, 2019, 05:16:17 pm
It's been quite a while since I checked in here. I am very glad that the forum still exists and the data spanning 14 years has been saved - many thanks for the huge effort to do so!

Over the years I have always read this site (as well as predecessor sites run by other enthusiasts) utilizing OmniWeb 2.7b3 on either my TurboColor NeXTstation or a Sun Sparcstation 5 (both under NS 3.3) and had very enjoyable experiences with the UI of the forum software of the time.
Alas, the same can't be said of this newer software - I will try working with it but looks quite "primitive". I guess this must be the evolution away from Berner-Lee's HTML to the Javas**t of today. We'll see how this post looks.

Also, should https > TLS1 be turned on, then NeXTboxen will be unable to ever use this site. Jurgen Mollenhof's https extension from 1999 for OmniWeb 2.x does SSL2, SSL3 and TLS1.