Debugging a dimension

Started by gtnicol, February 26, 2006, 07:57:15 am

Previous topic - Next topic

gtnicol

I have a dimension board that was in working condition, that apparently has quit. I swapped out the memory for known good memory... any ideas on what to check for next?

brams

Hi

Can you perhaps give us all a little more insight into what it does or does not do?

Do you have a mono monitor hooked up as well?

brams
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

Nitro

I remember seeing some information on the net about NeXTdimension L.E.D. error codes.  I believe there's five different codes the L.E.D. can flash at boot time.  You may be able to Google the old OPENSTEP.SE forums for more information.  Randy Rencsok has some NeXTdimension diagnostic software available but I haven't tried it.

http://www.channelu.com/NeXT/Black/NextDimension.tar.gz
Nitro

brams

I recall, if you trawl through comp.sys.next.hardware you can find the blink codes for the Dimension LED's.  I remember seeing them when I was trawling through looking for something else.

brams
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

brams

Found 'em, here they are:

http://groups.google.com/groups?hl=en&lr=&safe=off&num=10&q=dimension+led+group%3Acomp.sys.next.hardware&safe=off&qt_s=Search

Hope that helps and the Dimension is not FUBAR'd

brams
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

gtnicol

Thanks for the link to the blink codes.

It's a peculiar fault. The system apparently see it, but there is either no video signal, or the signal appears to be out of sync (diagonal lines of mixed RGB across the screen).

brams

Like the monitor is not syncing to the video signal?.  Have you got another computer with 13w3 to test the monitor & cable, another NeXT or an SGI?.    Is it a NeXT monitor they are getting on a bit these days, do you have another you can try an SGI or SUN one?

Is it giving any errors on the LED's?, I was bored at work today so I surfed through a few Dimension problems on comp.sys.next.hardware and it seems that most of the time it's bad ram, though some people have had NBIC problems and a RAMDAC failure.

I take it the Dimension was working fine and then failed, have you pulled the simms and reseated them, there seems to be a way if fitting simms, certain density pairs in certain sockets, probably would not hurt to pull them and clean the contacts and blow the sockets out with some air.  Maybe just put in one pair to see what happens.

A little off topic, but I once left my NeXTstation for a few months and it would not boot, it complained that the boot device had failed and kept saying the same thing all the time, I pulled the battery on the logic board and that fixed it.  Maybe it might be an idea to pull out the main board, ND and pull the simms (ND) and the battery and see if that works, sometimes the simple things work best.
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

gtnicol

I tested with a different Dimension board, which worked, so the display is OK. Then I swapped the memory and verified that the other dimension worked with it, and swapped it back.

Interestingly, sometimes the screen just stays blank, though with a monochrome hooked up, I can see the Dimension in the preferences pane.

I'll look at the blink codes tonight.

brams

Hmm that sounds serious if another Dimension worked with the RAM out of the bad one & in your Cube.

Other than it being a dodgy connector on the NeXTbus connector or a dry soldered joint somewhere, you might have a knackered Dimension, ouch!
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

gtnicol

Looks like 5 blink lights (they blink pretty fast). I had someone else count them too.

That's supposed to indicate the DRAM being bad, but the memory is tested good. I guess it's time to start hunting for problems with solder etc.

brams

Have you tried to put just the minimum amount of RAM in it?, AFAIK it needs pairs, but I also read that it uses 128 bit bus which would seem to suggest 4 simms (72pin simms are 32 bit right?, I seem to have forgot)

I also seem to recall Dimensions came out with 8mb on board so maybe you could say stick a couple of 4 or 8mb simms in.

It might be worth scanning the board with a magnifiying glass to look for dry solder joints.

Did you blow out all the sockets with air, I ask as I had an incident with a PC a few weeks ago at work.  The PC is in quite a dusty enviroment and one of the guys who works in the workshop that I manage came in complaining that it was mega slow.  I checked and it was only registrering 64mb ram, since the machine was running XP I knew this was the reason it was slow and I also knew the machine should have 128mb in it.  When I took of the side I saw a load of dust had been drawn inside the PC by the case fan and deposited by the CPU fan onto one of the Dimms/socket.  I took out the Dimm and blew out the mobo and sockets with compressed air and the machine again saw the 128mb, so basically the dust was causing it not to see one side of the Dimm.

The quality of NeXT PCB's is very high and I'd be surprised if it where a failure at that level.
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

gtnicol

I'm going to have to spend some fairly significant time on it I think. I'd probaly be best running the diganostics at some point.

I also wonder if the blink codes are accurate... they seem to be more for the motherboard than for the dimension per se.

brams

AFAIK the LED codes actually apply to NeXTstations as well, thus some of the codes may or may not affect the Dimension, VRAM error code for example.

Actually if you look at a NeXTstation logic board it looks very similar to a NeXTbus shape of card, it's been a while since I had thd lid of mine but I seem to recall seeing the edge connector on the board, leading me to suspect this.

A circuit diagram would come in handy does anybody have one?
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

gtnicol

Yes, a circuit diagram would be most helpful!

Has anyone else noticed the fairly significant differences between Dimension boards?

brams

I've seen the promo shots of the Dimension on various NeXT booklets & catalouges etc, they always seem to use what appears to be a prototype as it has the C-Cube JPEG chip mounted on the dimension board, rather than a daughter card.

Other than that I've not noticed any difference in production ones, however I've only ever seen two and they are both mine and PAL ones.  I've never seen an NTSC but maybe they where our before the PAL ones and had different/earlier revisions.
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.