NeXTStation raising exception on boot

Started by m18e, April 27, 2019, 04:16:33 am

Previous topic - Next topic


Starting just a couple days ago my NeXTStation started throwing an exception at boot:

Exception #3 (0xc) at pc 0x1000646 sp 0x4000600

Has anyone seen this before? It was working just last week :(

It's a Turbo Color, 128MB ram, and a CF AztecMonster compact flash -> SCSI 2 adapter.


Try disabling memory parity in the ROM setup.


Tried that, no joy :(

It seems to happen after the NeXT logo disappears, during the OS boot.


I'm not sure there is a formal explanation of that exception, but it's either RAM or SCSI related in my experience. Try removing SIMMs and a different HDD. Have the caps been replaced? Those are then the next likely suspect.


I've tried all combinations of memory sticks that I have. It seems to require two at a minimum; if I only use one it doesn't even begin the POST. Anyways, all the combinations I tried didn't make a difference.

I tried drives in, drives out, booting from the network (or, at least setting en/tp as the boot devices, not actually getting it to boot from the network).

Nothing's worked :(

Capacitors appear fine, nothing's leaking, bulging, or looking off... I wish I had a clue to what was going on.

The first time this happened I had tried using an LCD flat panel with a 13w3->VGA connector. The monitor supported sync-on-green but it said it was running at 1024x768, not 1120x832... could anything bad have happened from that? (It showed the POST boot splash fine, but it went to the exception prompt)


Have you tried pulling the battery? Let it sit for a while with the battery out.


I pulled the battery for a few minutes but no change. Does it need to be out for longer?


Given the sudden change and that you've eliminated the RAM and HDD as a concern I suspect the caps need to be replaced. You wont necessarily see any visual problems with them.


Okay, that's fine. Do you happen to know if there's a capacitor parts list kicking around?

I see 3 220uf 25V electrolytic capacitors on the motherboard; are those the only ones?

disregard! I found this topic:


I recapped the motherboard (all radial and surface mount capacitors swapped). One of the old surface mount caps looked like it was leaking after all. However, even after doing so, the same issue is happening. Same exception, same program counter, same stack pointer.

Any tips on where to look next?