Help installing

Started by jackxeus, May 11, 2016, 12:37:41 am

Previous topic - Next topic


TLDR: I am unable to run any apps downloaded from Next File Archive on NeXTStep 2.2 or 3.3 in Previous.

Full Version:
Greetings! This is my first post here, but I have read extensively on the forum to help get Previous up and running with NeXTStep 2.2 and 3.3. I could not have done it without all of the helpful tips and instructions here. I am working on my Masters thesis project which involves the history of the web, and I would like to do some hands-on research by interacting with the first browser, WorldWideWeb.

I have Previous 1.4 running successfully and I have versions of WorldWideWeb downloaded from the Next File Archive. I have created disk images that include the folder which I load in Previous. I can see the file in the File Viewer, but when I double-click I see the following message in the console "Workspace: Cannont exec /ba/ (not a valid program)". I get this same message with every other app I've tried downloading (with a different file name, of course). I've also tried copying the file to my apps folder, but it still did not work.

Am I missing some step to install the program?  Do I need to run some kind of command to perform an installation. Am I incorrect in using the .app file (e.g. should I use the tarball instead?).

I am sorry if I am totally off-base, but hours of research have left me with no where else to turn. I thank you greatly, in advance, for any help anyone can provide! :D


You should copy the original tarball into your previous install, and extract it natively within nextstep.

The "folder name" of your app is messed up, and appears to be the long file name truncation of Windows/DOS, which would also truncate all the names of the resource files in the app folder. Execute permissions for the app will also be messed up from extracting the tarball on Windows.


That make a ton of sense, I'll try that as soon as I get home. Thank you!