Trying to install Rhasody Medusa 1.2v3 on a G4 Cube

Started by jorisw, October 18, 2019, 04:00:00 pm

Previous topic - Next topic



I'm trying to install Rhasody Medusa 1.2v3 on a G4 Cube.

I know the machine's not officially supported, but through the configuration options in the (MacOS based) installer, I am able to get as far as "Sorry, couldn't set your machine to boot from the installation CD."

Then, I just reboot the machine myself, holding option, and select the part of the installation CD that is OS X based, which boots up the Rhapsody installer.

Then, it asks for a root device. I enter hd0, which brings up the following error message:

rootdev 300, howto 40001
cannot mount root, errno = 22

Also, before prompting me for the root device, it says the following about my hard disk:

hd0: IBM-DTLA-305020 TW2FA6AA
hd0: using DMA transfers.
registering: hd0
hd0: No Valid Disk Label
hd0: Device Block Size: 512 bytes
hd0: Device Capacity: 19623 MB

So, it recognizes the drive and it's capacity, but complains about a Disk Label. Is this part of the problem or an unrelated warning? I've tried to set a label using parted on a Ubuntu PPC live CD but frankly I'm not sure which label it expects.

If it's not related to the Disk Label: how do I get it to use the hard drive which it clearly does recognize? What am I supposed to format it as?

Drive Setup on the OS 9 portion of the installation CD, lets me select Mac OS X Server UFS, but fails to initialize the drive when I select it.

Has anyone ever run Rhapsody on a G4 Cube to begin with? Am I on a futile pursuit?


I have it running on one of my G4 Cubes.  It would not initially install and I almost gave up but with a few tricks it is possible.  I did the installation perhaps 7 years ago and my memory is a bit fuzzy but I remember the following:

  • Rhapsody USB implementation is extremely fragile and it will only work with the keyboard plugged into one of the USB ports on the bottom of the Cube and with the mouse plugged into the keyboard.  I also do not recall if it works with the "Pro" keyboard or if you need to use one of the older style keyboards.
  • I followed the standard installation instructions and I was getting an error message early during the installation.  From memory it was related to the hardware and/or storage.  If I recall correctly there was an option in the Rhapsody installer to allow an alternate installation means.  It worked for me.
  • Make sure your Cube has standard hardware configuration - no CPU upgrades, etc.

I wish I remembered more, but unfortunately I do not.and I do not really have any time for experimentation at the moment.


It would be super cool if we could get a working disk image. I tried and gave up on mine.