My emulation experience (Hyper-V and VirtualBox)

Started by rumbeard, February 16, 2019, 01:25:53 am

Previous topic - Next topic


So I jumped back into the fray with both feet because I got the itch recently.  I currently run a bunch of my home infrastructure on Server 2016 DataCenter Hyper-V, Windows 10 Hyper-V, and Server 2019 DataCenter Hyper-V... so naturally I thought it would be a good target.

Made a v1 host with ide setup, tulip NIC, and the standard graphic options.  After much tug-of-war I got a 90% functional system and believe it or not the graphics gave me 1152x864 at 32 bit using the S3 Trio PCI driver so it does work off the Hyper-V in 2016.  But I finally got to Network and I could bring up the tulip device but never pass packets so I binned that vm but I still had the bug.  I installed VirtualBox 5.2 on my work laptop and after some searching and combining install methods the best hardware for the job is:

Install with BusLogic SCSI
Faster than a scalded cat on my SSD boot vol.  Tell Virtual box to report it as an SSD too though I doubt it makes a difference.
I got everything working beautifully though the AMD PCNet is detected only as a 10Mbit card... but eh... it works
Sound I installed SB16 but that was a bit choppy/buggy so I got the SBSoundMIDI driver and chose the AWE32 which worked much better, however, playing many sounds resulted in stuck notes...bzzbzzbzzbzz endlessly.  Also realized this wouldn't be maximum fun because my work laptop had McAfee firewall and password protected settings.  No inbound fun.  So exported to an ova appliance... copied to my personal MacBook... import...

Sound fixed... amazingly fast.  I literally type my username and password and the desktop for root appears in like a fraction of a second.  The MBP is a Core i7 with an m2 SSD.

So I now run the thing headless at 1600x1200 32 bpp and use RDP or I run it locally as well but that would require scrolling at that huge resolution.  I've installed some goodies and now looking forward to happy hackage.