NeXT Computers Forum Index NeXT Computers
www.NeXTComputers.org
 
Log in to check your private messagesLog in to check your private messages

Log inLog in  RegisterRegister


Profile  Search  Memberlist  FAQ  Usergroups
NeXTStep 3.3 and sparcstation 10

 
Post new topic   Reply to topic    NeXT Computers Forum Index -> Sun / HPPA Hardware
View previous topic :: View next topic  
Author Message
mauve



Joined: 10 Jan 2009
Posts: 18
Location: Paris, France

PostPosted: Mon Jan 12, 2009 10:52 am    Post subject: NeXTStep 3.3 and sparcstation 10 Reply with quote

First, I wish to address my warmest thanks to all the contributors whose FAQs and documents were priceless in solving most of the problems I ran in when setting up my system ; I wouldn't have been able to do it without this help.

But let's reel back a little. I had that nice 10 / 512 MP with 179 MB ram sitting in my closet for more than a year, on which I used to run a webserver (debian linux). Having previously tried Solaris too, I thought I had quite a good grip on its quirks, and when I found some NeXTStep 3.3 CDs, I thought the time had finally come to revive it. I felt confident it would be nearly flawless. For some reasons, I've always been attracted to NeXTStep, ever since I read the 1988 account of the famed presentation of the system to the world in a computer mag, but never had the chance to run it first hand.

So I put my station back on line, made a few sanity checks with linux (still installed), and thought I was good to go.

details : the OBP is 2.14, disk 1 & 3 are 2 x 1GB for linux, disk 5 is a 2GB I was willing to dedicate to NeXTStep, and finally I had a cdrom unit as id #6.

1) my cdrom reader turned out to be unable to read the disks. Possibly shot, I had no other scsi unit with 512 Bytes/sectors capacity to try. So I scp'ed the iso to the station and dd'ed it on another disk unit, salvaged from a retired AS/400 RAID (the disk is 500 MB), and already re-sectored (AS/400 sectors are 520 bytes long). Hooked it as #6, reset, boot cdrom : no problems to select #5 as target for install. So far, so good.

2) First reboot. The doc I found in Apple KB says to boot on a disk different from #3, you can issue 'boot diskX' at the OBP prompt, where X is your unit #. Well, wrong, certainly not on my 10. I had to issue the whole device path, 'boot /iommu/sbus/espdma/esp/sd@5,0' ; took me a while to figure out, so I leave it here for posterity.
EDIT:
I had a chance to look at some Sun documentation about the OBP : only the first 3 scsi ids are bound to a diskX alias. Don't ask me why. Maybe - I'm reluctant to rebuild the system only to prove that point - this is the root (pun intended) of the subsequent mach failure to properly mount the newly installed disk as / (see further down).
/EDIT

3)Installation goes on flawlessly, time to reboot again.

4)I get a warning window with only "esc, intr, kill" and I'm thrown to a prompt. Why ? I type "exit", and the boot process grinds a bit before stalling. Hu Ho. Not good.

(some fiddling later)

77 Wink ) I managed to pass the -v option to the kernel ; damn, mach is looking to mount the first disk of the scsi chain on '/', and discards the unit #5 on wich it lives ! Oh, but there is the rootdev option ! I'm saved !

108) NeXTStep acts as if it can't care less about the rootdev option ; strange. It insists on being on the first disk. Out of hope, let's try the -a (ask ?) option ! Now, the boot command is something like "boot /iommu/sbus/espdma/esp/sd@5,0 mach_kernel -v -a"

172) It doesn't cut it either. For some reasons I can't explain, at the exact moment mach requests me to enter the rootdev, my keyboard ceases to function. Not once or twice, every single time ! I can't type anything.

So I've removed the 2 internal disks, only leaving the #5 attached. And finally, I was able to discover NeXTSTEP 3.3 in all its glory.

Question : did I do something wrong, or did I forgot something important ? The situation is not satisfactory, with the demise of my cd reader. I wish I could switch between linux and NeXTSTEP without a screwdriver.

EDIT :
I finally nailed it : I edited /etc/fstab and set sd2a as root. I then put back my internal disks where they belong, and started as usual. It works fine except for the warning as the disks are not in a known format. I've seen elsewhere the solution to this, so it's a mere annoyance that will be (hopefully) shortlived. All is well that ends well ? Not really. In the process of digging into the system, I discovered that the install process set up the disk as a 1GB unit instead of the 2GB available. So at the moment, I've 1GB missing, and don't know where the h*ll this space has gone...
/EDIT

But anyway, for what I saw, NeXTSTEP is awesome, and I'm truly happy to have managed the process so far. I write this experience also because I have a feeling the 10 being older than the 5 & 20, it has its own quirks, and I may very well have hit long forgotten bugs of that specific station.

EDIT :
After reading somewhere that a SuperSparc II SM71 would greatly boost NeXTstep on my hardware, I hunted one and got it from a really kind fellow nextstepper who was willing to part with one of his. At first, it was of no use because the SM71 really needs a prom > 2.22 to even *boot* the station. But said person was kind enough to burn a 2.25 prom for me, and I just swapped my 2.14 in favour of the newer one and, while it doesn't really makes the system fly (not expected with 75 MHz cpu anyway), it sure gives a bit of a kick. Overall, a recommended upgrade. I didn't took the pain to reinstall the system, it works as is, but does anybody knows if making a fresh install is recommended ? I was guessing perhaps a more optimised kernel image could be installed when a supersparcII was detected in the process (just a wild guess, haven't read anything on the subject) ?
/EDIT
Thanks again, your posts more than helped me.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeXT Computers Forum Index -> Sun / HPPA Hardware All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2017 phpBB Group