NeXT Computers Forum Index NeXT Computers
www.NeXTComputers.org
 
Log in to check your private messagesLog in to check your private messages

Log inLog in  RegisterRegister


Profile  Search  Memberlist  FAQ  Usergroups
VMWare Fusion networking problem solved!

 
Post new topic   Reply to topic    NeXT Computers Forum Index -> Emulation / Virtualization
View previous topic :: View next topic  
Author Message
andreas_g



Joined: 30 Jan 2009
Posts: 413
Location: Austria

PostPosted: Wed Oct 28, 2009 11:16 am    Post subject: VMWare Fusion networking problem solved! Reply with quote

Finally i have solved the networking issue, that existed for VMWare Fusion users since v2.0.1!

It was not possible to set up a network connection, because the VMXNet driver did not load correctly.

Now this is the solution:

Under Mac OS X find the file your virtual machine is stored in (usually it is called something like "name_of_your_virtual_machine.vmwarevm"). Open the file (package) as folder in the finder. Find "name_of_your_virtual_machine.vmx" and open it using TextEdit.
Within the file find the line: ethernet0.virtualDev = "e1000"
Delete this line!

That's it!

After booting NeXTStep (you will have to hit ctrl-c at some point during start up) go to the HostManager and open "local..." select "Use local domain only", "Readable only by local net" should be true. As hostname choose whatever you want, for the NIS domain name choose "none". Ignore network time!

Within the Finder open: "/Library/Application Support/VMware Fusion/vmnet8/dhcpd.conf"
There you can look up IP-adress, broadcast-adress, netmask and router-adress. Set your preferences, but do not reboot and quit HostManager.

Within NeXTStep open Edit.app and type only: "nameserver xxx.xxx.xxx.xxx" (where xxx.xxx.xxx.xxx is the adress of the domain-name-server, stored in dhcpd.conf, it is the same as the router-adress)
Hit "alt-shift-r" and save the file as "/etc/resolv.conf"

Now reboot and you should be able to surf the internet!

I hope i could help!

My setup: iMac (early 2009), Mac OS X v10.6.1, VMWare Fusion v2.0.6 running NeXTStep 3.3 with all patches


Last edited by andreas_g on Wed Feb 24, 2010 10:03 am; edited 2 times in total
Back to top
View user's profile Send private message Send e-mail
Morgon



Joined: 20 Mar 2006
Posts: 100
Location: Germany

PostPosted: Wed Oct 28, 2009 3:38 pm    Post subject: Reply with quote

Sounds reasonable that my driver can't load if Fusion tries to emulate an EtherExpress 1000 card as suggested by that configuration line.

The original VMWare network driver and thus my VMXNet are using an AMD PCNet32 for initialization before switching to the special VMWare mode.
Back to top
View user's profile Send private message
andreas_g



Joined: 30 Jan 2009
Posts: 413
Location: Austria

PostPosted: Thu Oct 29, 2009 4:56 am    Post subject: Reply with quote

It seems VMWare silently changed the default network adapter to the "e1000" with VMWare Fusion v2.0.1 and wrote the line to specify it to the .vmx files of all virtual machines.

Removing this line reactivates the previous default network adapter.
This is a little bit wired!
Back to top
View user's profile Send private message Send e-mail
andreas_g



Joined: 30 Jan 2009
Posts: 413
Location: Austria

PostPosted: Sun Jan 17, 2010 9:52 am    Post subject: Reply with quote

Edit:

My first post has been updated:

Do not delete the "localhost" entry using NetInfoManager. This will draw some applications (for example UserManager.app and NetInfoManager.app) unusable.
Back to top
View user's profile Send private message Send e-mail
aragon



Joined: 09 May 2007
Posts: 60
Location: Germany

PostPosted: Mon Jan 18, 2010 2:19 am    Post subject: Reply with quote

I followed your advice and deleted the 'localhost' entry.
Indeed, NetinfoManager did not work any longer.

I had to restore the Netinfo db from a copy and reboot to get it working again.
Back to top
View user's profile Send private message
pawel



Joined: 22 Feb 2010
Posts: 3

PostPosted: Wed Feb 24, 2010 7:13 am    Post subject: Reply with quote

Just tried this method, did't get it to work though. The boot now stops on "Starting network services" for 2.5min and then goes on and stops on "Starting automounter".


I'm not sure I followed you right. In HostManager after setting everything I started up Edit.app and made the "/etc/resolv.conf". Than I pressed "SET" in HostManager where I was followed by 3 statements and than a restart.

Am I not suppose to press "SET" in HostManager?
Also my "/Library/Application Support/VMware Fusion/vmnet8/dhcpd.conf" has a d
Back to top
View user's profile Send private message
andreas_g



Joined: 30 Jan 2009
Posts: 413
Location: Austria

PostPosted: Wed Feb 24, 2010 10:14 am    Post subject: Reply with quote

I obviously made a mistake in my instructions. As you told, the file is called "dhcpd.conf". I already corrected my initial post. Sorry about that.

Now to your problem:
If you follow the above instructions everything should work well. Personally I did first press "set" in HostManager.app, cancelled the reboot and then quit HostManager.app.
After that I set up "resolv.conf" and then did a reboot.
But I don't think this makes any difference from what you did.

Maybe your configuration got messed up at some point. You may try this:

Type into the Terminal:

rm -rf /etc/netinfo /etc/hostconfig
cd /usr/template/client/etc
cp -rp netinfo /etc
cp hostconfig /etc
reboot


After that you have to do some initial setup again (including setup of user passwords). Try to configure the network again. Follow the above instructions carefully. Maybe it was just a typing mistake you made at some point.
Back to top
View user's profile Send private message Send e-mail
pawel



Joined: 22 Feb 2010
Posts: 3

PostPosted: Wed Feb 24, 2010 10:39 am    Post subject: Reply with quote

Thanks a lot. I tried again...had the wrong IP-adress.

Now it works!

I got a few Kernel Panics when I googled around, but now it seems to work.

OT :I would need a good FTP-app. Can someone recommend one?

[img]http://www.rcheli.se/phpBB220/album_pic.php?pic_id=12391[/img]
Back to top
View user's profile Send private message
eagle



Joined: 29 Mar 2006
Posts: 389

PostPosted: Tue Jun 17, 2014 7:08 pm    Post subject: Reply with quote

Andreas, THANK YOU so much for this post!

I reinstalled OPENSTEP 4.2 tonight, into Fusion 6 on Mavericks. The vmxnet network driver wasn't working, and through some Google searches I found this post. Changing that fixed it.

Now I need to figure out how to get sound working...
_________________
My NeXTs:
NeXT Computer prototype (68030-25 x2, 68040-25)
Two NeXTstations (68040-25)
All mono
Back to top
View user's profile Send private message
emendelson



Joined: 06 Feb 2012
Posts: 10

PostPosted: Fri Aug 01, 2014 7:06 am    Post subject: Reply with quote

I just want to add my thanks. One added detail (which will be obvious to most users): when editing /etc/resolv.conf, you need to be logged in as root. Or at least I needed to be logged in as root.

Also, if you have a Windows VM installed on the same Fusion setup, you don't need to search for the Fusion conf file (which is now at a different location from the one listed in the original post). Just run the Windows machine, enter IPCONFIG at the command prompt, and get the router address from the output. As far as I can tell, this address will always be 192.168.xxx.2, but xxx will be different in different Fusion (or VMWare Workstation) setups.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeXT Computers Forum Index -> Emulation / Virtualization All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2017 phpBB Group