NeXT Computers Forum Index NeXT Computers
www.NeXTComputers.org
 
Log in to check your private messagesLog in to check your private messages

Log inLog in  RegisterRegister


Profile  Search  Memberlist  FAQ  Usergroups
OpenStep 4.2 on Compaq Evo N400c Howto

 
Post new topic   Reply to topic    NeXT Computers Forum Index -> White Hardware
View previous topic :: View next topic  
Author Message
kasbah



Joined: 05 Sep 2016
Posts: 1

PostPosted: Tue Sep 06, 2016 12:17 pm    Post subject: OpenStep 4.2 on Compaq Evo N400c Howto Reply with quote

Some Years ago a friend of mine gave me an original OpenStep 4.2 Box (greetings to m00d! Very Happy) and back then i managed to get it running in VMWare and kind of on my then still used Compaq N400c. After some playing, only grayscale VGA, no network and other uses for the laptop i put the OS into the shelf (Emulation is no fun Razz) to wait there till now! As some time later the N400c also became unused and went into the shelf i finally remembered and now i'm giving it another try with some more success so far! Smile I hope to get a nice working machine with network and sound at some point, but let's see how far i got so far ...

Requirenments:
- Compaq Evo N400c with Dockingstation equipped with Floppy Drive and CD or DVD Drive
- Custom Driver Disk -> found at the very helpful page from Laurent Julliard
- OS4.2
- OS4.2 Patch4 -> found here

The Installation is straight forward and works as Laurent Julliard described in his nice tutorial (although you have to select the Dual EIDE Driver to get access to the cd).
... until i came to the point after the first reboot where the installer asks for the driver floppy again. Then i just saw multiple "Disk Error: error 0x%02x" lines and the floppy did not load. After some experiments (including rewriting the floppy as i thought it broke) i found that not booting from the harddisk, but from the install floppy again and there at the prompt typing "hd()mach_kernel" made it work though. Don't ask me why, but the bootloader seems to break something when loaded from Harddisk and not Floppy.

Great, installation completed, now it is time to get some Hardware working:
First, i want to have at least some space at my screen (nowadays even the SXGA Display is lowres, but VGA is so small!), so i need a somewhat decent graphics driver. There are 2 options, with OS4.2 PATCH 3 you will get the VESA Driver, which of course works on the N400c. But, as the N400c has an ATI Rage, i did try the Driver from -> here. Yah, not working out of the box, but when looking in /private/adm/messages for an PCI-ID like *1002 i found 0x4C4D1002 for my particular model and added that in the Expert Settings to the Auto Detect IDs and voila a working full resolution 32bit screen is the result! Smile

Second, i'd like to have any network connection! Now i do have a CDRW to get files from my current machine to the OpenStep machine, but that is a complicated one way solution.

There is an Intel EtherExpress Pro/100 built into the N400c which is even detected, but it is not working, i only get "i82557eeprom: checksum fp65 incorrect : couldn't allocate eeprom object". Does anybody know a solution for this?

Second possibility would be a PCMCIA network card. I do own 3 different ones, but none of them is supported by OpenStep. Hmm, probably i have to by an Etherlink III 3c509 from ebay or so... although i would prefer to get the internal EtherExpress up and running of course.

Now ... it is time to get the development tools up and running, read documentation on configuring and tuning OpenStep, fix that network driver, write an audio driver and then hopefully have some fun looking at an old useless laptop with an old useless operating system where you'll never be able to watch youtube videos with. Wink But, of course, it will be much fun to explore the history of macOS and see the ground breaking NeXT system in action at home (for not much money at all)!

So, if you have tips and tricks on configuring OpenStep or writing drivers, don't hesitate to immortalize them in this thread! Wink
Back to top
View user's profile Send private message
kolli



Joined: 28 Aug 2016
Posts: 7

PostPosted: Wed Sep 07, 2016 5:57 am    Post subject: Reply with quote

I went into a similar problem with the floppy on a Compaq Deskpro 2000 system (Pentium 133). I solved it by putting the hard disk in another Computer and installing there. Maybe Compaq used some not fully compatible floppy controller...

In case of the NIC my advantage was to use a desktop computer. So I had the choice and found a PCI card with (I think) a Realtek 8029, that was working with the NE2000 driver. Graphics went well with the onboard Cirrus Logic, so I have a working system.

But because it is kind of slow, mainly due to only 24 MB of RAM, I switched to installing and testing software on a VM and later transferring the whole disk image to a real HD. :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    NeXT Computers Forum Index -> White Hardware All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2017 phpBB Group