Trying to install Rhapsody Medusa 1.2v3 on a G4 Cube

Started by jorisw, October 18, 2019, 10:00:00 AM

Previous topic - Next topic



I'm trying to install Rhapsody Medusa 1.2v3 on a G4 Cube.

I know the machine's not officially supported, but through the configuration options in the (MacOS based) installer, I am able to get as far as "Sorry, couldn't set your machine to boot from the installation CD."

Then, I just reboot the machine myself, holding option, and select the part of the installation CD that is OS X based, which boots up the Rhapsody installer.

Then, it asks for a root device. I enter hd0, which brings up the following error message:

rootdev 300, howto 40001
cannot mount root, errno = 22

Also, before prompting me for the root device, it says the following about my hard disk:

hd0: IBM-DTLA-305020 TW2FA6AA
hd0: using DMA transfers.
registering: hd0
hd0: No Valid Disk Label
hd0: Device Block Size: 512 bytes
hd0: Device Capacity: 19623 MB

So, it recognizes the drive and it's capacity, but complains about a Disk Label. Is this part of the problem or an unrelated warning? I've tried to set a label using parted on a Ubuntu PPC live CD but frankly I'm not sure which label it expects.

If it's not related to the Disk Label: how do I get it to use the hard drive which it clearly does recognize? What am I supposed to format it as?

Drive Setup on the OS 9 portion of the installation CD, lets me select Mac OS X Server UFS, but fails to initialize the drive when I select it.

Has anyone ever run Rhapsody on a G4 Cube to begin with? Am I on a futile pursuit?


I have it running on one of my G4 Cubes.  It would not initially install and I almost gave up but with a few tricks it is possible.  I did the installation perhaps 7 years ago and my memory is a bit fuzzy but I remember the following:

  • Rhapsody USB implementation is extremely fragile and it will only work with the keyboard plugged into one of the USB ports on the bottom of the Cube and with the mouse plugged into the keyboard.  I also do not recall if it works with the "Pro" keyboard or if you need to use one of the older style keyboards.
  • I followed the standard installation instructions and I was getting an error message early during the installation.  From memory it was related to the hardware and/or storage.  If I recall correctly there was an option in the Rhapsody installer to allow an alternate installation means.  It worked for me.
  • Make sure your Cube has standard hardware configuration - no CPU upgrades, etc.

I wish I remembered more, but unfortunately I do not.and I do not really have any time for experimentation at the moment.


It would be super cool if we could get a working disk image. I tried and gave up on mine.


Thanks t-rexky.

Good to know that it is at least possible. I had pretty much given up seeing as the above error message regarding the root device wouldn't go away, no matter what I tried in Disk Utility.

Your part about allowing additional configurations I did use: it's part of the Mac OS 9 based installer which initially says it's the wrong kind of hardware. I think I got a stock G4 Cube with no upgrades.

Would you happen to remember at all if you're running 1.2v3 or some other version?

Also, would anyone happen to know if the root device error message is related at all to the "No valid disk label" warning? Is that something I need to worry about at all?


I will see if I can get some time together before the end of the year to retrace my installation steps and, if successful, I will image the drive.



Time is still in short supply here, but I was able to fire-up one of my stock Cubes with the Rhapsody 5.6 drive in it.  Good news is that it still works perfectly!  For now, I made a short video of the setup, startup and shutdown: G4 Cube Rhapsody.mp4

A few notes:

  • I recall that I had to buy older Apple USB keyboard for it to work, Model M2452.  I did not check again with the USB Pro Keyboard but will try later if time allows.
  • You cannot use the monitor USB hub - the keyboard has to be plugged into USB port 2 on the Cube.  The boot will hang with the keyboard plugged into USB Port 1.
  • I had the mouse plugged into the keyboard.  The USB Pro Mouse works fine.
  • The Cube is in complete stock configuration with ATI video card (I think it's Rage 128).

I need to find a small EIDE drive to attempt a clean re-install of Rhapsody.


Hi, I'm interested too, is there any chance that you share your HDD image with us ?


Wow, that is pretty awesome.  Makes me wish I still had my G4 Cube.
My NeXTs:
NeXT Computer prototype (68030-25 x2, 68040-25)
Two NeXTstations (68040-25)
All mono


No worries, I will definitely image the drive once I do a clean install.  I just need time...



Ok, another update:

Once you use connect the keyboard model that I have as shown in the video and connect it as shown therein, there is nothing else specific about installing Rhapsody on the Cube.  It will tell you that the system is unsupported, you have to then select the option to install on an unsupported system, and then it installs to completion without any issues.

I will complete the installation with developer tools and then make a downloadable image. 



Downloadable image with some instructions is now available from my DropBox:

I hope Rob or Nitro throw it into the file archives here, since I'm running out of space on my DropBox...



Holy crap! I never thought I'd see a cube running a Rhapsody incarnation! Bravo!  ;D
Mr. Intel
<br />
<br />