Issues Building on Linux Mint 21.1

Started by wlewisiii, February 02, 2023, 11:58:15 AM

Previous topic - Next topic

wlewisiii

Cloned and built SDL2 from Git.

Finally figured out how to checkout from SVN. Downloaded and built the branch_softfloat release with --disable-rendering-thread

Used make install to install the binary.

attempt to run the binary from /usr/local/bin/Previous and get this error:
Previous: symbol lookup error: Previous: undefined symbol: SDL_ResetKeyboard

But if I attempt to run the binary in the build directory previous-build/branch_softfloat/src, it appears to work fine but after selecting a diskimage (from my Previous install on Windows 10) and rom file. I get to the ROM 3.3 monitor and (very possibly I'm misremembering what to do) b sd0 fails.

Any ideas? Thanks in advance.

andreas_g

Not sure why the installed binary has linking problems. But for the usage issue: It should work with just "bsd".

wlewisiii

Sorry, I must be missing something...

b ,,bsd gets me the usage error

,,bsd gets me huh?

b sd(,,bsd) bsd not found.

b sd(,,,)bsd gets a bsd not found as well.

I'm sure it's something simple but I'm not sure of my memory or of my build.

andreas_g


wlewisiii

But only after you've reset the emulator or it won't see it.

Thank you for your patience. I appreciate it. I'll keep puttering with the linker (perhaps it's in whatever version of SDL got cloned?) but this at least gets me moving forward.

wlewisiii

Do'oh... "sudo ldconfig" :o

Now to get networking going 8)