NEXTSTEP 3.3 on HP 9000 712/100

Started by commodorejohn, May 21, 2018, 12:16:03 AM

Previous topic - Next topic


I picked up this nice little PA-RISC pizza-box a while back and, since I have bigger, badder hardware for experimenting with HP-UX and current BSDs don't seem to get along with the 712s, I've been thinking it'd be fun to try running NEXTSTEP on it. I can successfully boot the install disk, set up the hard drive, and get all the way through the graphical installer, but when I try to boot the new install, I get the issue a few other people seem to have encountered here where it hangs indefinitely at "starting file service daemons."

I've tried the suggested fix of deleting /etc/netinfo and /etc/hostconfig and copying them over from the templates folder, but all this does is get the system booting from the NEXTSTEP graphical console instead of the HP framebuffer console - the boot process errors out in exactly the same way. I've also tried poking around in /etc/rc and commenting out the commands under the "file service daemons" section, but this just causes the boot process to choke entirely at that point and kick me to a single-user prompt.

Can anybody weigh in on what might be causing this issue, and how to fix it? The hell of it is, I actually had NEXTSTEP successfully booting from a different hard drive, but the installer got confused by the existence of a 9GB disk and decided it was actually a 200MB disk, so I repurposed that for one of my SGI systems. I've tried two other 2GB disks that the installer recognizes and works with happily enough, and both of them give the same erroneous result described above.


Well, I finally figured it out. Turns out the installer set up /etc/fstab under the assumption that the hard disk would be located at /dev/sd0* when in fact the CD-ROM drive was located there. The reason it worked for me on the first, too-large disk was that I'd disconnected the CD-ROM drive in between doing the install and booting the system. Once I removed the CD-ROM drive again after doing a fresh install on the just-right disk, the hard disk was located where /etc/fstab expected it to be and the system was able to boot normally.

Which means that I now have a functioning NEXTSTEP installation on my 712! Well, okay, functioning but not exactly a full proper setup. Still need to figure out how to get networking setup correctly, and what I really want is the development tools, which don't appear to be where they're supposed to be on the install CD; the NextDeveloper folder contains only a "Demos" folder and nothing else. Any idea where I can get the PA-RISC versions of the development tools?


I think you are looking for the "NeXTStep Developer"-package.

It was sold as a separate package.


Indeed, but I can't find the PA-RISC version anywhere...


If my memory serves me right, the NS3.3 Developer CD is quad-fat, meaning it has executables and libraries for all four supported architectures...


Rob Blessin Black Hole

Hello: I have downloadable NeXTSTEP 3.3 Developer iso image  , I can sell you for $29 helps keep the lights on I just drop box it to you .  Yes it is quad fat.  Also have an original NeXT 3.3 Developer Disk  $99. best Regards Rob Blessin
Rob Blessin President computerpowwow ebay  [email protected]
303-741-9998 Serving the NeXT Community  since 2/9/93


I actually already got myself a copy of the 3.3 Developer software, I just didn't know it was all-architecture (after seeing some search results for a specifically PA-RISC 3.2 Developer CD, I assumed they were architecture-specific, but I suppose 3.3 was probably the first unified release for the RISC architectures...?)