NEXTSTEP & OPENSTEP in Virtual PC 5

Started by brams, January 06, 2006, 08:05:21 AM

Previous topic - Next topic

brams

Somebody kindly posted on www.openstep.se the method on how to set up OPENSTEP routing & DNS within Virtual PC 5, I think it was based on the information on this page:

http://u1.netgate.net/~snowcat/OpenStep.html

But has some differences.

Please can sombody post it if they have it?

brams
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

rice0067

I followed the instructions on that page and got networking to work on NS 3.3 in vpc 7 (image converted from install on vpc 5) The only thing that didnt seem to work was the nameserver so I just added the address of the real one from verizon into my resolv.conf

I suspect that having DHCP running in NS would be much more simple.
(not that these directions are hard).

Back in 2000 I had DNS, DHCP and apache? running nicely on my turbo color.
For lack of a modern browser I would still use it :(

brams

Hi

When I did it, I could not ping my router and I was using an IP not a name so resolv.conf is not the trick, I will try again in case I did something wrong.  I had it setup perfect using the instructions of openstep.se and then for some reason I installed it again by which time openstep.se had gone down and since then I've not been able to get it to work.

I've got no problem with any of my NeXT's, they are networked OK.

VPC 7 for Macintosh?, everything I've tried when booting of a converted image from VPC 5 results in a panic in the virtual machine, but thats using OS 4.2, NS 3.3 works does it?

Edit:

I tried it and NS 3.3 does indeed work under VPC 7.  I converted the image from VPC 5 to 7 and then it booted fine.  I've never tried NS 3.3 under VPC 7 before but assumed it didn't work as I and a few others have never managed to get OS 4.2 to convert or install on VPC 7, which leads to the question, why does OS 4.2 panic under VPC 7? it happens very early on and I always suspected it to be the IDE driver.
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

brams

I got networking working under VPC 5, I editied resolv.conf to the same IP as the gateway 192.168.131.254.

Converting this image then to VPC 7 and the network does not work.  DEC NIC is seen during boot.  I think the MAC addresses changed from VPC 5 to 7 and thats why it won't work?
NeXTcube Turbo Dimension, NeXTstation Turbo Color, MP2100, Q840av, Q650, WS G4 500, Pismo G4 550, SGI Octane R12K MXE, BeBox 133.

Venture37

your best bet is to use Guest PC on OS X
Daxziz mentioned it worked on openstep.se, I gave it a go & it all worked out well