Slirp, PCAP and Previous 2.0 or 2.2

Started by ugubser, September 28, 2020, 12:44:32 PM

Previous topic - Next topic

ugubser

Hello everyone,

so I've managed to compile and run Previous on different Linux' - I'm also running the 2.0 binary for Windows 10.

With Linux, I've managed to setup Slirp and I can telnet back into the host. But on the host (NS3.3) I can only ping 10.0.2.2 and nothing else (so no dns on 10.0.2.3 etc.). I feel like I'm not understanding how Slirp is supposed to work. Does anyone have a crash course?

The same can be said about PCAP - I'm not sure how it's supposed to work. I think it's a network monitoring tool that let's you capture network traffic. But I can't seem to set it up correctly. I run Previous as root and then bind to Ethernet interface where I run my network but after that, I don't know if I have to do something on the host or not.

Any help much appreciated.
thanks


Rob Blessin Black Hole

Hello : Do you have UNIX Expert set in Preferences under root? 

Here is the Cable modem guide http://www.nextcomputers.org/NeXTfiles/Docs/TjLs_Cable_Modem_Guide.pdf

This should help as well NeXT Network and System Administration guide http://www.nextcomputers.org/NeXTfiles/Docs/NeXTStep/3.3/nsa/

Also you should have it available in NeXTstep if you installed the documentation package
under the directory NextLibrary bookshelves check the man pages docs as well.




Rob Blessin President computerpowwow ebay  [email protected] http://www.blackholeinc.com
303-741-9998 Serving the NeXT Community  since 2/9/93

ugubser

Hi,

so I read through the cable modem guide but the only thing I can glean from that is how to NOT run it as a netinfo node (which I followed and disabled netinfo). Bit this doesn't appear to be the problem. I set the IP address, the route, the broadcast etc. according to how-to-network readme file and also again with the localhost configurator. And I can ping the "routers" IP and I can even telnet into the host remotely (on port 42323). What I don't understand is how slirp or PCAP is supposed to work thereafter because I can't do anything else after pinging the router or logging in remotely.
Specifically, it mentions that it creates a service on 10.2.2.3 for DNS lookups, however that doesn't work for me and it just stalls. Someoen else had the same problem on Previous on Windows (I've tried with the latest 2.2 on Ubuntu and with the 2.0 windows version) - Meanwhile, I also managed to get the compiled mac version to run with the same problem.

So I think I'm missing something fundamentally- it seem that slirp is more meant as a way to tunnel, so do I need to run a client on my Linux or Windows machine for that?

For PCAP I'm at a total loss how that's supposed to work.

I've added some screenshots - maybe it helps for the understanding where I'm at.

thanks.
Urs


ugubser

Ok, so I think I solved it somewhat. I read in another thread that someone was making changes directly to the slipr source code to redirect ports on the host to the emaulator. So I just redirected a bunch of ports (copy & pasted), incl. ssh and http and now it seems to work better. At least, I can browse the web and I can FTP. I still can't do an nslookup but somehow the browser can (OmniWeb). I'm very confused.