Can't get Openstep 4.2 networking under VirtualBox.

Started by asdf, March 13, 2021, 09:08:35 PM

Previous topic - Next topic

asdf

Hi there. This is a frustrating post as I had no problem with NS 3.3 on my NeXT boxes years ago. I'm using the VirtualBox appliance found in this[1] thread.

The appliance is setup to use bridged networking by default and this doesn't work in my setup (I don't know why).. Next I tried NAT, but networking still doesn't work.

Confusing this setup is the fact that VirtualBox doesn't tell me what the network setup should be under nat (192.168.1.x, 10.0.0.x, 10.0.2.x, ...?) . It expects guest VM's to use DHCP.

I would use DHCP, but I can't create an ISO (Images created by disk utility on Mac fail with NS erring on a bad NSString in the console).

Could someone document network setup for OS4.2 in VirtualBox? Or perhaps post an iso with the DHCP client so I can install it on OS4.2.



[1] http://www.nextcomputers.org/forums/index.php?topic=4512.0

asdf

A little more detail.

Nat configuration
I can ping myself on both local and network interfaces (192.168.0.9).
On boot up if I chance any network settings from the appliance configuration network services hang and boot up takes several minutes before timing out.

 Host is setup on a typical 192.168.0.x network.

     Host IP 192.168.0.16
     router 192.168.0.1
     net mask 255.255.255.0
     bcast 192.168.0.255
     DNS 192.168.0.1

In Openstep
   Guest IP 192.168.0.9
   router 192.168.0.1
   net mask 255.255.255.0
   bcast 192.168.0.255
   DNS 192.168.0.1

pTeK

Any more news, I'm having the same problem installing OpenStep 4.2 (Intel) on Virtual Box 6.1.38_Ubuntu r153438.

I followed the installation process from http://openstep.bfx.re/

I've installed the 4.2 patch.
The NE2K driver I had to rename from ne2k_091betamibtar.gz to ne2k_091betamib.tar.gz to extract and then install it.

My Network Settings:
x Enable Network Adapter
  Attached to: Bridged Adapter
 Name: wlp2s0 (my lubuntu wireless driver)

 Advanced
 Adapter Type: PCnet-PCI II (Am79C970A)
 Promiscuous Mode: Allow All
 Mac Address: Mac hex address
 x Cable Connected


codepoet80

Creator of the appliance here -- haven't used it in years, however, I did document my efforts (both with a VM and with real hardware). Perhaps something in these posts will help?

https://www.jonandnic.com/2008/06/26/installing-nextstep-33-on-vmware-6/
https://www.jonandnic.com/2020/08/28/nextstep-openstep-nfs-file-share-with-a-raspberry-pi/

pTeK

Quote from: codepoet80 on April 25, 2023, 11:10:19 AMCreator of the appliance here -- haven't used it in years, however, I did document my efforts (both with a VM and with real hardware). Perhaps something in these posts will help?

https://www.jonandnic.com/2008/06/26/installing-nextstep-33-on-vmware-6/
https://www.jonandnic.com/2020/08/28/nextstep-openstep-nfs-file-share-with-a-raspberry-pi/
Hi.

 I'm still not having much luck. I went and used some information from the jonandnic.com as I was setting up NextStep3.3 and OpenStep.

 I also saw on the VirtualBox forums that the GNUStepLeadDeveloper was having trouble with setting up networking and they said that the way NextStep / OpenStep set's up PCI seems to be different from other systems.

 I'm still slowly working on it, may have to look into SLIP over serial

pTeK

It seems that even though NeXTSTEP is based on BSD with networking it doesn't have SLiP tools that NetBSD, FREEBSD have which come standard, back to the drawing board

boomer3200

Bridged over wifi is really problematic.  Can you use a cabled host card to bridge?

Also, you would want to be sure you are using the pcnet and not the ne2k driver with VirtualBox.

pTeK

I've swapped to PCNET but only have wireless on the laptop.

from Lubuntu shell I type.

vboxmanage natnetwork list

I then try to add the network that is listed with

boxmanage modifyvm OpenStep --natnet1 "192.168.4.0/22"

Now the emulator boots up, but the emulator can't find the web.

i.e ping 8.8.8.8 or www.netbsd.org does not have any luck

pTeK

This has now been solved  :)

My Network Settings.

Screen shot of Network setup in Virtual Box
After reading the following site:

Guest network settings for Virtual Box

-- Beginning of text from Virtualbox site --

In NAT mode, the guest network interface is assigned to the IPv4 range 10.0.x.0/24 by default where x corresponds to the instance of the NAT interface +2. So x is 2 when there is only one NAT instance active. In that case the guest is assigned to the address 10.0.2.15, the gateway is set to 10.0.2.2 and the name server can be found at 10.0.2.3.

If the NAT network needs to be changed, use the following command:

$ VBoxManage modifyvm VM-name \
--natnet1 "192.168/16"
This command would reserve the network addresses from 192.168.0.0 to 192.168.254.254 for the first NAT network instance of VM-name The guest IP would be assigned to 192.168.0.15 and the default gateway could be found at 192.168.0.2.

-- End of text from VirtualBox site --

I then setup my network in Host Manager like is mentioned in the TjL / Cable Modem document fouund on this site for me it's.

I open up a terminal/shell and I (I have no 'root' password set, login as 'root' if you have a password set)

su -
cd /NextAdmin
Hostmanager.app/HostManager

The following are my settings

Screen shot of Network setup in OpenStep 4.2
[img="https://ibb.co/CMSvBNB"]https://ibb.co/CMSvBNB[/img]

for those that don't want to click the image.
** NetInfo Binding **
x use local domain only

** Hostname **
 Autoconfigure
x mynext  <-- Custom

** NIS Domain Name **
x none

** Internet Address **
  Autoconfigure
x 10.0.2.15   <-- Custom (like it says on the Virtual Box page above)

** Broadcast Address **
x 10.0.2.255 <-- Custom

** Time Standard **
x Use Network Time

** Netmask **
 Default
 Automatic
x 255.255.255.0  <-- Custom

** Router **
 None
 Dynamic
x 10.0.2.2  <-- Custom