SCSI.blue work/better than SCSI2SD

Started by zombie, August 10, 2021, 04:59:29 PM

Previous topic - Next topic

mlroider

Hi

Just picked up a BlueScsi V2 card and I am attempting to install a fresh version of Openstep on it.
The card comes up during boot from Floppy / CD install process and I have the ROM disk off and the bytes per sector and heads set property.  But as soon as it starts the install it errors out with Cannot initialize the disk.  Is this a know issue?  Should I build the image elsewhere?

Thanks

nuss

Hi mlroider, I have not yet tried installing onto BlueSCSI, but used existing disk-images with OpenStep and NeXTstep.

How did you create and what is the size of your hard drive-image files on the BlueSCSI?
What are the names of this hard drive-image files?
DON'T PANIC

cuby

What is the size of the disk image you are trying to initialize?

NeXT/OpenStep has limits at least in the size of partitions (2 GB for NeXTstep, 4 for OpenStep IIRC), see this thread for details.

mlroider

Its a 1.4 gig image ... just using the empty one from the default previous package

Nitro

I haven't tried to install directly to the drive yet. I created an image on a second Compact Flash drive first using a disktab on a turbo color slab. Then I put the CF card in a USB card reader and used Linux dd to save it to an image file. Since the image I used has seven 2 GB partitions, I formatted the microSD card with the exFAT file system. I then copied the 14 GB image file to the microSD card and named the file per instructions in the video by @MacintoshLibrarian posted earlier in the thread. It's important for the naming convention of the disk image file on the microSD card to match your device. I hope that helps you get things running.
Nitro

mlroider

Sort of got it working.  I was able to use an existing clean image of OS 4.2 and it booted right up.

CygnusTM

Just for another datapoint, I've been using a BlueSCSI v2 internal and external with a Mono Slab. Things have worked well, even CD emulation. I was seeing some errors on one of the drives, but then I noticed that the BlueSCSI was reporting that the drive file was fragmented. I copied the files off the SD, reformatted, and copied them back. The problems disappeared. I've had no other problems. Running NS3.3 and OS4.2.

I had been using a SCSI2SD before that, which was working fine with a single disk, but I could never figure out how to copy an image to a second disk. BlueSCSI is so much easier to use for multiple disks.

Nitro

How To Build BlueSCSI v2 ... and also WiFi! - JCM Live

Video starts around 90 seconds in.

Nitro

paolo.bertolo

The wi-fi is for Mac only, as it relies on some drivers for a specific SCSI to Enet legacy device which is now emulated. I'm using a v2.0 on 68k Macs and it just... works. Highly recommended.

NeXTnewbe

I think the BlueScsi needs to include audio as clicking sound like a real old vintage hdd,that will be amazing :D