Yet another probably dumb question

Started by wlewisiii, February 25, 2023, 11:29:21 PM

Previous topic - Next topic

wlewisiii

As part of the process to get ACL running under 3.3, you need 2 libraries from the 3.0 cd.

I downloaded the iso and listed it in the configuration screen. But when I log in as Me it complains that the SCSI disk is unreadable. The boot messages say there's an invalid checksum. This has happened with all the ISO's I've tried.

Is this an issue like the floppies or do I just have bad iso's?

Thanks!

cuby

Which libraries do you need? You could try to extract them from one of the available 3.0 disk images using ditool included with Previous (ditool doesn't work with CD images so far, unfortunately).

The shlibs on my 3.0 disk image here are

libIndexing_s.A.shlib libdsp_s.A.shlib libsys_s.B.shlib
libMedia_s.A.shlib libmusic_s.A.shlib libvideo_s.A.shlib
libNeXT_s.C.shlib libni_s.A.shlib
libdbkit_s.A.shlib libphone_s.A.shlib


wlewisiii

According to the thread here: http://www.nextcomputers.org/forums/index.php?topic=2898.msg16959#msg16959

I need these two:

/NeXTSTEP_3.0/lib/libsys_p.a  cp to /lib/libsys3.0_p.a
/NeXTSTEP_3.0/usr/lib/libNeXT_p.a cp to /usr/lib/libNeXT3.0_p.a

cuby

First, some bad news - the only NeXTstep 3.0 CD Image I could find on the net (on fsck) is corrupt, probably the same image mentioned here. I couldn't mount it in Linux and NeXTstep in Previous also complains, see the attached screenshot.

Now for the good news - I have an original 3.0 CD and was able to extract the libraries. Please find a zip file attached. Good luck! :)

Screenshot 2023-02-26 at 16.39.09.png
next30libs.zip 

wlewisiii

Thank you so very much. Both for the libraries and for letting me know that the images are bad.

cuby

You're very welcome! I just tried to get Allegro CL to work on 3.3 and was successful using instructions from this thread.

It just took me a while to find the "meta" key in emacs (it's the Escape key on NeXTstep), this binary patch is quite ugly...

wlewisiii

Hmm. I'm running into a problem running the build script. When it goes to link the executable, I get a ld error about the table of contents of the library being out of date. LibNeXT took ranlib fine but I get an error about cpu type on libsys during the ranlib run and the linker won't link. I am presuming you had no such problem with that.

The patch wasn't a big problem for me but just can't get everything to link correctly.

cuby

I also encountered the CPU type problems when trying to link against the _s.a libraries I also copied from 3.0.

For the successful build, I copied libsys_p.a and libNeXT_p.a from NeXTStep 3.0 to /usr/cl/build. Then I ran sh ./config for the first time (which failed to link) and edited ucl.o in emacs as described.

Finally, I changed the config shell script as follows to instruct the linker to use the _p versions of the libraries and remove libdsp:

LIBRARIES = -lNeXT_p -lsys_p
USYMS =

and ran sh ./config again. That's all...

wlewisiii

/bin/ld: static.o symbol 0 (_fastab) can't be a weak definition. (currently only supported in section of type S_COALESCED)

exit 1

stop

(the sound you hear is my head hitting my desk... )

cuby

Hm, strange, maybe we're using a different NeXTstep version or different dev tools? I used the "Nextstep 3.3 HD Image With Previous" from winworldpc as a basis and added the 3.3 dev tools on top (plus the two 3.0 libraries I posted, of course).

I can try to setup the image from scratch later today to see if I can reproduce my result...

cuby

I just did an install from scratch in Previous and could successfully link and run ACL. The Allegro Common Lisp version I used was the two floppy installer from fsck.

Can you provide a complete log of the installation/executing the config shell script?

wlewisiii

Ok, took a vanilla disk image, set it up with passwords, installed the developers tools.

But when I went to install ACL from the disk image it errored out with checksum errors on disk 2. That may well be what my problem is. Of course now I have to find non broken ACL images.

cuby

I also have the checksum error and ignored it :).

wlewisiii


wlewisiii

Ok, building it from scratch on a image with only the dev tools installed (no patches) worked. Tar file moved to my primary image works fine.

Now I just have to figure out why my shell tool is acting screwy :LOL: