Seagate ST32550N not recognized by my NeXTcube

Started by hc105, March 03, 2023, 02:11:59 PM

Previous topic - Next topic

hc105

Just trying to replace my (very) old 800Mb 5"1/4 internal disk drive by something less old, heavy, slow, big, etc.
I've tried with a ST32550N (actually, I've tested on three diffent items, same type), but each time my cube starts, I got the following message:
sc: Didn't complete
sc: Didn't complete
...
(every 10 seconds or so)

If I boot over the net, I got additionnal messages:
sc: Didn't complete
sd: target 0 lun 0 opcode 18
sd: addr 0x43bbf50 bcount 66 rdflag 1
sd: sdstatus 0 sdstate 0 resid 66
sc: s5c state 1 status 0x0
sc: intrstatus 0x0 seqstep 0x0
sc: fifo level = 7 transfer count 43690
sc: command 0x42 config 0x57
(also, every ~10 seconds)

I've tried different jumper settings as I assume this should work... but no success so far.
Can't see anything with our "friend" Google.

Any help would be more than appreciated.

barcher174

Do you hear the drive spin up? Tested in another system? Those kind of messages are usually a drive hardware fault.

dramirez

I would suggest to test the hard drive on a Macintosh and check if SCSI Probe sees it properlly.

Another option could be to connect it to a Linux system with a SCSI adapter and check dmesg | grep sd, lsblk, fdisk -l /dev/sdx, etc.
Restoring a NeXT Cube with a Dimension board.