NFSManger vs. mount

Started by tygre, November 26, 2023, 09:46:22 PM

Previous topic - Next topic

tygre

Hi all!

I have set my network, a NFS share, and my NeXTstation and everything works fine except that I cannot get NFSManger to behave :)

When I mount the NFS share from the command line as:
mount -t nfs CHAMSAE:/media/Archives /Net/ArchivesThe NFS share /Net/Archives is created as expected and I can browse its content (located on CHAMSAE in /media/Archives).

When I use NFSManager, I fill in the same info. and the GIU shows a line like:
CHAMSAE    /media/Archives    /Net/CHAMSAE/media/ArchivesBut when I double-click on /Net/CHAMSAE, nothing happens except a busy pointer for a while. (I also tried cd into it from the command line, it freezes for a little while and then replies "No such file or directory".)

I read these posts (1, 2, 3, and 4) but I'm still unsure of the best solution. I don't understand why the mount command line works but not NFSManager. I'm not sure if I should modify fstab and what I should put in it because the syntax seems different from that of the mount command line.

Am I missing something with NFSManager? What would be the simplest and safest solution to have the share mounted with every boot?

Thanks in advance!
Tygre

Nitro

I used this informative article when I was setting up my Raspberry Pi NFS server a while back. Hopefully that will help to get things working for you.
Nitro

tygre

#2
Thanks Nitro! :)

I missed that page! It explains exactly my problem: "On NeXTStep 3.3, the NFSManager.app GUI was not able to successfully mount the share" and suggests to use /etc/rc.local...

Off I go try that ;D

tygre

PS. Everything works like a charm using mount in rc.local 8)

fstark

Trying to have the NFS server working. I enabled ethernet (twisted pair) and have my home directory as the shared folder. I tried to follow the instructions in filesharing.howto.txt, but it says (quite logically) that the server 'nfs' is not found.

How do I specify the embeded NFS server? I feel that I am missing something obvious there...

(oops, wrong thread, will post in the Previous mega-thread)